[gelöst] Anpassen Reseller-Account: Ändern des Reseller-Accounts wegen Überschreiten von Limits nicht möglich

  • Hallo,

    ich wollte gerade den Account (Vertrag) eines Resellers anpassen und bekomme beim Speichern immer folgende Fehlermeldung:

    "Durch das Speichern dieses Vertrages werden einige hierauf basierende Verträge ihre Limits überschreiten ("overprovisioning"). Möchten Sie fortfahren?"

    Klicke ich die Checkbox an, kann ich trotzdem nicht fortfahren.Ich kann leider auch nicht den Webspace und den E-Mail-Space ändern, dass es passt. Da kann ich eingeben, was ich möchte ...


    Er meldet z.B. aktuell "Die Anzahl der Postfächer darf nicht größer sein als die Anzahl der Adressen.". Bei beiden ist jedoch als Wert "unbegrenzt" hinterlegt.


    Ferner wird bei Benutzer gemeldet, dass zwei Accounts des Resellers das Limit bei einem unbegrenzten Wert überschreiten.


    Kennt jemand das Problem bzw. die Lösung?

  • Ich konnte jetzt teilweise etwas herausfinden. Die Liveconfig-Logs hatten folgenden Inhalt:
    InputException: exceeded.0.account (*****), exceeded.0.properties.0 (users), exceeded.1.account (*****), exceeded.1.properties.0 (users)

    Eigentlich passten immer die Anzahl an Nutzer, ich habe die aber trotzdem erhöht und danach war die Fehlermeldung weg.

    Aktuell habe ich nur noch immer die Fehlermeldung "InputException: mailboxes (Die Anzahl der Postfächer darf nicht größer sein als die Anzahl der Adressen.)"

    Den Fehler kann ich immer noch nicht auflösen.

  • Konnte selbst alle Probleme lösen. Am Ende musste man in der Datenbank die Fehler suchen. In einem Fall waren es unbegrenzte Mailboxen aber begrenzte Adressen, dann wiederum ein nicht-komplett konfigurierter Account. Der Vergleich zwischen den Werten bei HC_MAILADDRS und HC_MAILBOXES in der Tabelle "HOSTINGCONTRACTS" hat mich am Ende zum Ziel geführt.

    Ein offensichtlicheres Logging im Debug-Modus wäre hier sehr wünschenswert! Oder aber Informationen in der Benutzeroberfläche.

  • marinal

    Hat den Titel des Themas von „Anpassen Reseller-Account: Ändern des Reseller-Accounts wegen Überschreiten von Limits nicht möglich“ zu „[gelöst] Anpassen Reseller-Account: Ändern des Reseller-Accounts wegen Überschreiten von Limits nicht möglich“ geändert.

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!