Posts by mgoeben

    Hallo!


    der lcpolicyd ist ja nun seit einigen Jahren aktiv, die Dokumentation spricht auch davon, dass die Einstellungen pro Vertrag oder per E-Mailadresse definiert werden können.
    Leider ist das nicht der Fall.
    Mir würde es fürs erste aber schon reichen wenn es einen Default Wert gäbe.


    Gruß


    Marco Göbenich

    Hi!


    Danke für den entscheidenden Hinweis, ich hatte die virtual_alias und virtual_domains Textvariante nicht mitkopiert, in dem Gedanken dass Liveconfig die eh neu schreibt, aber es wird nur bei Änderungen nur genau die Änderung geschrieben.


    :thumpup für eine Option in liveconfig alle Konfigdateien neu zu genieren.


    Gruß


    Marco

    Hallo


    Ich habe das Problem dass der Postfix immer sagt dass die mail auf ihn selbst loopt und dass er den Benutzer nicht findet.
    die virtual_aliases und virtual_domains sind aber quasi leer.


    Ich habe sie auch schon neu generieren lassen, durch Anpassung der Postfix Konfiguration im Liveconfig, aber die Dateien bleiben leer.


    Ich weiß nicht mehr an welcher Stelle ich noch suchen soll.


    Installiert ist die Version 2.9.3.


    Gruß


    Marco

    Hallo!


    Da ja klammheimlich ohne weitere Nennung im Changelog und Forum anscheinend die Unterstützung für Gentoo beeendet wurde, wollte ich mal fragen ob es trotzdem noch das tar.gz zum selbst weiter führen des Ebuilds gibt.
    Ich würde mein System schon gerne weiter updaten können., Beziehungsweise sollte der neue Server eigentlich auch liveconfig bekommen.
    Ihre Gentoo Unterstützung war eigentlich der Grund sich für Liveconfig zu entscheiden.


    Gruß


    Marco Göbenich

    Hi!


    Dem würde ich wiedersprechen wollen da keine Ratelimit gebrochen wurden. mit dem E-Mail Account wurde zwei weitere Zertifikate beantragt, im gleichen Zuge.
    Und der erste Fehler:

    Code
    [2016/09/11 21:28:47.458386] [7380|31935] HTTPClient: state != READ_DATA (5)
    [2016/09/11 21:28:47.458501] [7380|31935] ACME: newCert(): unexpected content-type '(null)'
    [2016/09/11 21:28:47.458522] [7380|31935] ACME: newCert() failed. Status=0, response=(null)
    [2016/09/11 21:28:47.458547] [7380|31935] ACME: can't get certificate for 'juz-zweiteheimat.de':


    läßt eher auf verbindungsprobleme tippen,


    Seitdem kommt nur noch:

    Code
    [2016/09/11 23:04:47.345089] [7380|12076] ACME: newCert() failed. Status=429, response={
    "type": "urn:acme:error:rateLimited",
    "detail": "Error creating new cert :: Too many certificates already issued for exact set of domains: juz-zweiteheimat.de,www.juz-zweiteheimat.de",
    "status": 429
    }


    Das Zertifikat wurde auch genau da zu diesem Zeitpunkt erstellt, aber nicht heruntergeladen.


    Das Rate Limit kommt nur deswegen zum tragen, weil ich das defekte Zertifikat gelöscht habe und dann ein Neues zu bestellen. Im Liveconfig war übrigens keine Fehlermeldung zu sehen. Außer das das Zertifikat erstellt wurde (valid). Zertifikat ist aber nicht hinterlegt.


    Danke

    Hallo!


    Ich habe ein neues Zertifikat beantragt, aber aus irgendeinem Grund wurde das Zertifikat nicht heruntergeladen (obwohl es existiert).


    Kann man das nochmal irgendwie manuell Anstoßen.


    Anbei das Log:


    [2016/09/11 21:28:47.458386] [7380|31935] HTTPClient: state != READ_DATA (5)
    [2016/09/11 21:28:47.458501] [7380|31935] ACME: newCert(): unexpected content-type '(null)'
    [2016/09/11 21:28:47.458522] [7380|31935] ACME: newCert() failed. Status=0, response=(null)
    [2016/09/11 21:28:47.458547] [7380|31935] ACME: can't get certificate for 'juz-zweiteheimat.de':
    [2016/09/11 21:44:47.405173] [7380|1724] HTTPClient: state != READ_DATA (5)
    [2016/09/11 21:44:47.405272] [7380|1724] ACME: newCert(): unexpected content-type '(null)'
    [2016/09/11 21:44:47.405296] [7380|1724] ACME: newCert() failed. Status=0, response=(null)
    [2016/09/11 21:44:47.405324] [7380|1724] ACME: can't get certificate for 'juz-zweiteheimat.de':
    [2016/09/11 22:00:46.942946] [7380|3933] HTTPClient: state != READ_DATA (5)
    [2016/09/11 22:00:46.943061] [7380|3933] ACME: newCert(): unexpected content-type '(null)'
    [2016/09/11 22:00:46.943088] [7380|3933] ACME: newCert() failed. Status=0, response=(null)
    [2016/09/11 22:00:46.943112] [7380|3933] ACME: can't get certificate for 'juz-zweiteheimat.de':
    [2016/09/11 22:16:46.802939] [7380|6010] HTTPClient: state != READ_DATA (5)
    [2016/09/11 22:16:46.803096] [7380|6010] ACME: newCert(): unexpected content-type '(null)'
    [2016/09/11 22:16:46.803124] [7380|6010] ACME: newCert() failed. Status=0, response=(null)
    [2016/09/11 22:16:46.803166] [7380|6010] ACME: can't get certificate for 'juz-zweiteheimat.de':
    [2016/09/11 22:32:46.757871] [7380|8174] HTTPClient: state != READ_DATA (5)
    [2016/09/11 22:32:46.784349] [7380|8174] ACME: newCert(): unexpected content-type '(null)'
    [2016/09/11 22:32:46.784369] [7380|8174] ACME: newCert() failed. Status=0, response=(null)
    [2016/09/11 22:32:46.784391] [7380|8174] ACME: can't get certificate for 'juz-zweiteheimat.de':
    [2016/09/11 22:48:47.498169] [7380|9984] ACME: newCert() failed. Status=429, response={
    "type": "urn:acme:error:rateLimited",
    "detail": "Error creating new cert :: Too many certificates already issued for exact set of domains: juz-zweiteheimat.de,www.juz-zweiteheimat.de",
    "status": 429
    }
    [2016/09/11 22:48:47.498229] [7380|9984] ACME: can't get certificate for 'juz-zweiteheimat.de': Error creating new cert :: Too many certificates already issued for exact set of domains: juz-zweiteheimat.de,http://www.juz-zweiteheimat.de
    [2016/09/11 23:04:47.345089] [7380|12076] ACME: newCert() failed. Status=429, response={
    "type": "urn:acme:error:rateLimited",
    "detail": "Error creating new cert :: Too many certificates already issued for exact set of domains: juz-zweiteheimat.de,www.juz-zweiteheimat.de",
    "status": 429
    }
    [2016/09/11 23:04:47.345157] [7380|12076] ACME: can't get certificate for 'juz-zweiteheimat.de': Error creating new cert :: Too many certificates already issued for exact set of domains: juz-zweiteheimat.de,http://www.juz-zweiteheimat.de
    [2016/09/11 23:20:47.624621] [7380|13926] ACME: newCert() failed. Status=429, response={
    "type": "urn:acme:error:rateLimited",
    "detail": "Error creating new cert :: Too many certificates already issued for exact set of domains: juz-zweiteheimat.de,www.juz-zweiteheimat.de",
    "status": 429
    }
    [2016/09/11 23:20:47.624683] [7380|13926] ACME: can't get certificate for 'juz-zweiteheimat.de': Error creating new cert :: Too many certificates already issued for exact set of domains: juz-zweiteheimat.de,http://www.juz-zweiteheimat.de
    [2016/09/11 23:36:46.865157] [7380|15830] ACME: newCert() failed. Status=429, response={
    "type": "urn:acme:error:rateLimited",
    "detail": "Error creating new cert :: Too many certificates already issued for exact set of domains: juz-zweiteheimat.de,www.juz-zweiteheimat.de",
    "status": 429
    }

    Hi!


    Im Gentoo ebuild fehlt ein inherit auf user, damit enewuser und enewgroup als Befehle vorhanden sind und


    Der Fehler fiel mir nur deswegen auf, weil der Benutzer immer beim Update gelöscht wird und wieder angelegt wird, das sollte natürlich nicht passieren, da ja alle Dateien, die mal Liveconfig gehörten damit verwaisen.


    Gruß


    Marco

    Hallo!


    Das Passwort Feld ist sofort ausgefüllt, und es ist nur der Chrome Passwort Manager.
    Tatsächlich habe ich sogar noch eine zweiten hier, den habe ich aber extra deaktiviert nach Ihrem Hinweis auf Passwort Manager.


    Es gab im Chrome Passwort Manager einen Eintrag für genau dieses Passwort ohne Benutzername, habe das nun gelöscht, jetzt kommt es nicht mehr, vielleicht existierte dieser Eintrag noch aus der Zeit bevor die Verhinderungsmaßnahmen eingebaut wurden.


    Gruß


    Marco

    Ok sehe den Fehler. Das Gentoo ebuild entfernt beim Update seit der letzten Änderung den user liveconfig.


    Das postrm macht ein bisschen zu viel, der eben geprüfte oder erstellte Benutzer wird automatisch gelöscht.

    Hi!


    Das hat es bei mir auch gelöst! Dafür ist mein Custom Logo im Admin Account verschwunden und ein erneuter Upload schlägt fehlt:
    [2 015/12/08 22:06:04.712974] [22480|22487] Error while creating temporary file '/var/lib/liveconfig/htdocs/logo57d0740ac6.png' for logo upload: Permission denied


    Gruß


    Marco

    [2015/11/26 15:00:38.552330] [19748|25377] ACME: challenge for 'www.needful.de' failed: Invalid response from http://www.needful.de/.well-kn…PQHkeACJIPk8Kk53xM7TDdUKo [85.214.107.135]: 403
    [2015/11/26 15:01:36.334287] [19748|25705] ACME: challenge for 'needful.de' failed: Invalid response from http://needful.de/.well-known/…kle53OZluggp8vFQoam8FBndI [85.214.107.135]: 403


    Wenn die Links selbst aufrufe bekomme ich


    Forbidden


    You don't have permission to access /.well-known/acme-challenge/ne1Ag_kpXYRmpI5tNvkle53OZluggp8vFQoam8FBndI on this server.

    Keine Ahnung was der Beitrag mit dem 10 Zeichen bedeutet, hier funktioniert das schlicht nicht. Ich weiß auch nichtwie man das weiter debuggen kann oder manuell ausführen, damit ich mir die Meldungen ansehen kann.

    Hallo!


    Leider kommt weiter nur invalid! Habe das Zertifikat komplett neu angefordert.
    Die Meldung mit dem sslv3 kommt anscheinend von einem alten Browser. Hat also nichts damit zu tun.


    Gruß


    Marco Göbenich