Posts by aho546745

    Mittlerweile hab ich herausgefunden, dass kunden-seitig die Problem-Adresse extra definiert war und daher vom Catchall nicht erfasst wurde, die Änderung wurde dann während meiner Debug-Versuche vorgenommen. Das mit dem Neustart war Zufall. Ich wollte das nur erstmal hier schreiben, damit niemand auf Fehlersuche war, tatsächlich war - da haben sie recht - der Neustart des Postfix nicht die Lösung.

    Mittlerweile hab ich herausgefunden, dass kunden-seitig die Problem-Adresse extra definiert war und daher vom Catchall nicht erfasst wurde, die Änderung wurde dann während meiner Debug-Versuche vorgenommen. Das mit dem Neustart war Zufall. Ich wollte das nur erstmal hier schreiben, damit niemand auf Fehlersuche war, tatsächlich war - da haben sie recht - der Neustart des Postfix nicht die Lösung.

    Hat sich erledigt, siehe unten


    Servus,


    seit eben registriere ich ein weiteres seltsames Verhalten.


    Ich habe mehrere Catchall-Adressen eingerichtet, für diese kann man den Spamassasin nicht einschalten.


    Trotzdem werden Emails abgewiesen:


    Code
    Jan  2 20:51:33 server6 lcsam[925]: 69.169.224.107: REJECT (SPAM 0.0/0.0/0.0 DKIM_SIGNED,DKIM_VALID,DKIM_VALID_AU,DKIM_VALID_EF,HEADER_FROM_DIFFERENT_DOMAINS,HTML_FONT_LOW_CONTRAST,HTML_IMAGE_RATIO_06,HTML_MESSAGE,RCVD_IN_MSPIKE_H2,SPF_HELO_PASS,SPF_PASS), From: =?utf-8?Q?M=C3=BCnchner=20Singles=20Team?= <team@muenchnersingles.de>, To: testadressex@example.com, MessageID: <01070185740a0962-192f9870-7f66-454b-b16d-8a324ede2d56-000000@eu-central-1.amazonses.com>, Subject: =?utf-8?Q?E-Mail-Adresse=20best=C3=A4tigen?=
    Jan  2 20:51:33 server6 postfix/cleanup[1100185]: 8D7225C0276: milter-reject: END-OF-MESSAGE from b224-107.smtp-out.eu-central-1.amazonses.com[69.169.224.107]: 5.7.1 Your message was rejected because it appears to be spam; from=<01070185740a0962-192f9870-7f66-454b-b16d-8a324ede2d56-000000@eu-central-1.amazonses.com> to=<testadressex@example.com> proto=ESMTP helo=<b224-107.smtp-out.eu-central-1.amazonses.com>


    Wie kommt den Liveconfig dazu, bei nicht eingeschalteten Spamfilter hier einfach Emails abzuweisen?


    Spannend ist, dass das nur bei einer bestimmten Emailadresse auftritt, bei einer anderen Catchall-Adresse nicht.


    Was nicht geholfen hat: Löschen der Catchall-Adresse und Neu-Anlegen


    Edit: Gelöst durch Neustart des Postfix.


    Danke und Gruß, Andre

    Edit: Gelöst, siehe unten


    Servus,


    LiveConfig 2.15.0 auf Debian 11.6 folgendes Fehlverhalten:


    Ich unchecke unter Email -> Adresse/Konto anklicken -> Spam-Filter "Greylisting" und speichere rechts unten, keine Änderungen in liveconfig.log, keine Deaktivierung des Greylistings.


    Habe Liveconfig neu gestartet, anschließend das selbe Verhalten, allerdings dann wenigestens je Änderung an den Spamfilter-Einstellungen ein Eintrag im Log:


    Code
    [2023/01/02 20:35:08.053370] [1094476|1094481] [LUA] Adding/updating user account testkonto1@example.com at dovecot config file: /etc/dovecot/passwd
    [2023/01/02 20:35:15.873478] [1094476|1094482] [LUA] Adding/updating user account testkonto1@example.com at dovecot config file: /etc/dovecot/passwd
    [2023/01/02 20:35:24.381951] [1094476|1094480] [LUA] Adding/updating user account testkonto2@example.com at dovecot config file: /etc/dovecot/passwd
    [2023/01/02 20:35:29.814235] [1094476|1094481] [LUA] Adding/updating user account testkonto2@example.com at dovecot config file: /etc/dovecot/passwd


    Weiß jemand,


    • wie man Liveconfig dazu bekommt, die Änderungen am Spamfilter zu übernehmen?



    Manuelles Durchstarten des Postfix half


    Danke und Gruß, Andre

    Bei mir erkennt nach einem Dist-Upgrade von Debian9 auf 11 LC das FPM aus dem Debian Paket nicht.
    Ich erhalte dann:


    "[2022/03/20 23:29:56.038336] [115292|115296] [LUA] PHP version nil configured as FPM for subscription xxx but no PHP found for this version!
    [2022/03/20 23:29:56.038571] [115292|115296] [LUA] PHP version nil configured as FPM for subscription xxx but no PHP-FPM found for this version!
    "


    Da ich noch mitten um Update bin, hab ich wenigen betroffenen Webs auf FCGI umgestellt.
    Das Paket php7.4-fpm hatte ich aus dem Debian Repo installiert, den FPM gestartet, aber LC hat den FPM nicht erkannt, trotz Neustart. LUA-Dateien habe ich nicht angelegt.


    Anton: Deinen letzten Beitrag verstehe ich so, dass LC dies einfach so hätte erkennen sollen? Falls ja: Was mache ich falsch?

    Servus, kennt jemand diesen Fehler und weiß Abhilfe?


    Code
    [ERR] addPHP: missing parameter 'cgi' (FastCGI binary required!)
    [ERR] selected PHP default version 'nil' not found! Using 'nil'...


    Fällt mir auf, seit Wechsel von Debian 8 auf 9.
    Der Fehler tritt auch dann auf, wenn nur PHP Opt Pakete installiert sind, die aus dem LC-Repo kommen.



    Inhalt der Datei /usr/lib/liveconfig/lua/custom.lua:


    Code
    postfix.NOUPDATE = true


    Danke und Gruß, Andre

    Das Problem trat während eines Debian Upgrades auf, ich habe das dist-upgrade allerdings nicht komplett durchgeführt, sondern vorerst einzelne Dienste selektiv updated.


    Als noch nicht alle Pakete updated warten und das Debian noch der Meinung war, auf Version 8 zu sein, trat der Fehler auf, auch bei diversen Neuerzeuge-Config-Versuchen.
    Nachdem das System auf Debian 9 komplett hochgezogen war, hat LC beim nächsten erzeugen der Config den problematischen Parameter nicht mehr in die Config geschrieben.


    Um das mit systemd einzurichten, einfach den Befehl "systemctl edit lcsam.service" ausführen und folgenden Override anlegen:

    Code
    [Service]
    ExecStart=
    ExecStart=/usr/lib/liveconfig/lcsam -g spamd -U postfix -r


    Danach lcsam neu starten (systemctl restart lcsam.service).


    Wenn ich das mache dann erhalte ich:


    Code
    X-Virus-Scanned: Debian amavisd-new at ....
    X-Amavis-Alert: BAD HEADER SECTION, Improper use of control character (char 0D
            hex): X-Spam-Report: ...server6..de",       has NOT
            ident[...]


    Der X-Spam-Report wird vom Spamassi selbst erzeugt oder manipuliert den lcsam in irgendeiner Art und Weise? Laut Google tritt das aber wohl häufiger auf und scheint daher wohl nicht von lcsam zu kommen