Beiträge von weltmeister

    Von unseren Kunden haben wir mehrfach hinweise bekommen, dass der Server verbindungen zum Mailkonto abbricht oder verweigert. Nach Recherche bin ich auf folgenden Fehler und diese Abhilfe gestoßen:


    Zitat

    Warning: service(imap-login): process_limit (100) reached, client connections are being dropped


    Lösung:


    https://randomit.de/dovecot-process_limit-reached/


    bearbeiten der Datei /etc/dovecot/conf.d/10-master.conf und anpassung des folgenden Wertes: process_limit = 200


    Nun meine Frage, da alles über LiveConfig verwaltet wird und die Einstellung "process_limit" deaktiviert war: ist es möglich, das diese Einstellung mit z.B. einem künftigen Update angepasst wird, so das der Wert z.B. standardmäßig verdoppelt wird und nicht auskommentiert ist?

    Die Entwicklung läuft voll auf Hochtouren, aktuelle Schwerpunkte sind in der Tat Backup und Mail.


    ... vielen dank das ist sehr erfreulich. Bitte auch die anderen "Kleinigkeiten" nicht außer acht lassen! Manchmal sind es Dinge, die uns oder dem Kunden das leben leichter machen. Was u.a. auch wichtig wäre ist: https://www.liveconfig.com/de/…-PHP-Mail-und-etc-aliases


    Das Problem besteht nach wie vor, das Kunden per php-Mail an teilweise nicht erreichbare Mailadressen senden, im glauben, dass grundsätzlich alles beim Emfänger ankommt. Irgenwann läuft die Mail-Queue regelrecht über, da der jeweilige Return-Path nicht in der /etc/aliases steht.


    Die Wunschliste ist lang, ganz oben steht neben dem Backup auch ein Dateibrowser, wie bei P***k.


    So und nun feuer frei! ;)

    Danke, alle Updates sind fehlerfrei durchgelaufen. Wenn nun hoffentlich alle Bugs beseitigt sind, kann's ja an die größeren Dinge, wie z.B. u.a. Backup-Funktion, Mail-Blackliste usw. gehen, oder sehe ich das falsch? ;)

    Es handelt sich um Stretch.


    - läuft der Dienst überhaupt auf Port 21 (lsof -i :21)?
    ---> keine Ausgabe, vermutlich weil der Dienst nicht läuft


    - läuft proFTPd überhaupt (ps aux| grep -i ftp)
    ---> Ausgabe: root 27974 0.0 0.0 12784 976 pts/0 S+ 10:53 0:00 grep -i ftp
    Sollte also nicht laufen.
    Im LiveConfig wird der Dienst als aktiv angezeigt
    liveconfig ---diag zeigt ebenso an, dass proftpd installiert ist.


    - was steht in der /var/log/proftpd/proftpd.log?
    ---> Nichts. Die Datei ist 0 kb groß und hat keine Inhalte.


    Es ist sicher nur eine Kleinigkeit, und ich denke ich stehe auf dem Schlauch und brauche einen Denkanstoß.
    Ich bedanke mich an dieser Stelle auch für die bisherige Hilfe.

    Die Ausgabe sagt folgendes:



    Im Liveconfig wird der Dienst jedoch als aktiv angezeigt und Passwörter usw. kann man auch ändern... Hat noch jemand einen heißen Tipp?


    Längerfristig soll LiveConfig eine Möglichkeit erhalten, sämtliche Konfigurationseinstellungen eines oder mehrerer Benutzer in eine XML-Datei zu exportieren, die dann auf dem neuen Server importiert werden kann (und dort automatisch ggf. die Accounts wieder anlegt usw.) - das sollte einen Umzug erheblich vereinfachen.


    Wann gibt es diese Funktion?


    Habe aktuell das Problem, dass der FTP-Server spinnt.


    Zitat

    ECONNREFUSED - Verbindung durch Server verweigert


    In den Logs steht nicht bedeutendes dazu, alles andere funktioniert tadellos. Der Dienst ist aktiv und läuft, auch Passwort-Änderungen haben nichts gebracht.


    Hat jemand einen Tipp?

    Nachtrag: löscht man die IP unter Serververwaltung ---> Datenbanken ---> Zugriff erlaubt:... bleiben auch die Einträge in der Datenbank bestehen. Das sollte so nicht sein, d.h. wenn ich die IP entferne, müssen auch die entsprechenden Einträge in der Datenbank verschwinden.

    Selbes Problem hier. Ändert man die IP für den externen Zugriff, werden vorhandene IPs in der Datenbank nicht aktualisiert, nur wenn man neue Datenbanken anlegt, stehen dann die neuen IPs in der DB, vorhandene Datenbanken bleiben unberührt. Wie kann man das Problem kurzfristig lösen?

    Ein frisch installierter Server (Debian9) mit lcclient, liefert bei mir permanent folgende Fehlermeldung:




    Das ganze ist auch eher wieder ein "kosmetischer" Fehler.
    Da es noch keinen Account auf dem Server gibt, ist die Fehlermeldung logisch.
    Kann aber unter Umständen zu Verwirrungen führen.


    Das selbe Problem haben wir auch - was ist zu tun?