Nach Server Umzug teilweise kein FTP Zugnag mehr [GELÖST]

  • Hallo Leute,


    ich habe einen Server Umzug gemacht und alles wie beschrieben in Liveconfig vollzogen! Nun so wie es aussieht, geht inzwischen das meiste bis auf einige FTP Zugänge nicht mehr! Einige gehen und andere nicht " Kritischer Fehler bei der Verbindung etc." Unbekannter Benutzer -> abgewiesen!


    Was mach ich falsch oder besser wie kommen die entsprechenden User wieder auf Ihren Webspace per FTP? Kann ich das irgendwo nachvollziehen wo die Usernamen und Passwörter abgelegt werden?

    Sind bei Kopieren mit rsyc Daten verloren gegangen? Wo setze ich an? Kann Liveconfig das regeln und neu einlesen oder zurücksetzten?


    Mfg. Thomas

  • Du hast die Config neu schreiben lassen und verifiziert, dass die Passwort-Datei in /etc/proftpd/ liegt?

  • Du hast die Config neu schreiben lassen und verifiziert, dass die Passwort-Datei in /etc/proftpd/ liegt?

    Ja habe ich, ich vergleiche alles immer noch mit dem alten Server, dort ist nichts verändert, alles so wie es dort vorher lief!

    Und die passwd ist identisch mit dem alten Server, aber da liegen nur die zusätzlichen FTP-Accounts drin, die ein Kunde angelegt hat! Also

    in meinem Fall nur 4 Stück und nicht alle anderen die zum Account des Kunden mal erstellt worden sind. Ich kann auch in Liveconfig

    reingehen und das Standard Passwort ändern, aber auch hier tut sich nichts es kommt auch keine Fehlermeldung, man kann sich nicht einloggen

    in den FTP auch nicht mit dem geänderten Passwort.


    Ich dachte, es gibt bei Liveconfig ne Art Befehl zum Reorganisieren der Tabellen und Passwörter, falls was nicht hinhaut! Genau so hat Liveconfig Probleme

    mit den Sites-enabled und sites-available in etc/Apache2/ die Dateien zu editieren! Immer wenn ich was ändere in Liveconfig erstellt er eine userdir(nr.).conf.tmp

    und ändert die vorhandene nicht ab, die tmp Datei ist zudem ach nur halb erstellt! Ich weiss im Moment echt nicht was da nicht stimmt! Dateirechte und Gruppenrechte passen alle wie beim alten Server auch. Sicherlich gibt es hier auch keine generelle Funktion die seites-enable neu erstellen zu lassen?


    Mfg. Thomas

  • Ja habe ich, ich vergleiche alles immer noch mit dem alten Server, dort ist nichts verändert, alles so wie es dort vorher lief!

    Und die passwd ist identisch mit dem alten Server, aber da liegen nur die zusätzlichen FTP-Accounts drin, die ein Kunde angelegt hat! Also

    in meinem Fall nur 4 Stück und nicht alle anderen die zum Account des Kunden mal erstellt worden sind. Ich kann auch in Liveconfig

    reingehen und das Standard Passwort ändern, aber auch hier tut sich nichts es kommt auch keine Fehlermeldung, man kann sich nicht einloggen

    in den FTP auch nicht mit dem geänderten Passwort.

    beende einmal den proftpd auf beiden Kisten, sichere die Passwort-Datei und kopiere nochmals die (und nur diese) die Password-Datei vom alten Server drüber. Danach den Proftpd neu starten und nochmal testen…

  • beende einmal den proftpd auf beiden Kisten, sichere die Passwort-Datei und kopiere nochmals die (und nur diese) die Password-Datei vom alten Server drüber. Danach den Proftpd neu starten und nochmal testen…

    Leider nein, immer noch das gleiche kein Login möglich! Liegt es an Debian 12? Ich weiß es nicht, bin echt Ratlos! Auf Debian 9 lief alles unproblematisch, aber weil ich drei Shopsysteme bei Kunden drauf habe und die Updaten sollte, ging das Theater los Debian 9 hatte php 7.3 drauf und die neue Shopsoftware wollte unbedingt min. PHP 8.0 oder höher. Da ich für Debian 9 keine Repositorys mehr bekommen habe und demzufolge auch keine Updates mehr, habe ich mich entschlossen auf das neuste Debian hochzustufen (Debian 12). Und seit dem habe ich jetzt Murks und keinen, der mir helfen kann!


    Mfg. Thomas

  • Leider nein, immer noch das gleiche kein Login möglich! Liegt es an Debian 12? Ich weiß es nicht, bin echt Ratlos! Auf Debian 9 lief alles unproblematisch, aber weil ich drei Shopsysteme bei Kunden drauf habe und die Updaten sollte, ging das Theater los Debian 9 hatte php 7.3 drauf und die neue Shopsoftware wollte unbedingt min. PHP 8.0 oder höher. Da ich für Debian 9 keine Repositorys mehr bekommen habe und demzufolge auch keine Updates mehr, habe ich mich entschlossen auf das neuste Debian hochzustufen (Debian 12). Und seit dem habe ich jetzt Murks und keinen, der mir helfen kann!

    Wenn Du möchtest, kann ich morgen früh auf Deine Kiste schauen. Gib einfach Bescheid…

  • Problem gelöst!!!!!! SOLVED


    Es fehlte lediglich ein Modul: "proftpd-mod-wrap"

    Und das :

    Code
    /usr/sbin/proftpd --configtest -c /etc/proftpd/proftpd.conf

    brachte mich auf die richtige Spur ! Er beschwerte sich in der Ausgabe das er mod-wrap.c nicht finden und somit nicht laden konnte

    und in der folge auch das gesamte modules.conf verweigerte zu laden!


    Nun geht alles wie gewünscht, der Rest funktioniert auch alles endlich, nachdem ich die fehlende Standart php8.2-cgi nachinstalliert habe!


    Ich danke euch für eure angebotene Hilfe, ihr seid klasse, vielen lieben Dank noch mal.


    Mfg. Thomas

  • thopoh

    Changed the title of the thread from “Nach Server Umzug teilweise kein FTP Zugnag mehr” to “Nach Server Umzug teilweise kein FTP Zugnag mehr [GELÖST]”.
  • Wenn Du möchtest, kann ich morgen früh auf Deine Kiste schauen. Gib einfach Bescheid…

    Evtl. kannst du ja mir auch bei diesem Thema helfen?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!