htaccess Datei

  • Hallo, wir haben in unserem Kundenaccount folgende .htaccess Datei gelegt:


    Apache Configuration
    AddDefaultCharset UTF-8
    
    
    RewriteEngine on
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l
    RewriteRule .* index.php [L]


    Leider funktioniert diese Regel aber nicht... mod_rewrite ist aktiviert.


    P.s. Ein Test rewrite zu google geht aber. Wir haben auch das 1:1 von Confixx kopiert da ging es aber noch.


    Im Log ist nur das zu sehen:
    [Sat Aug 31 11:40:14 2013] [error] [client xxx] Negotiation: discovered file(s) matching request: /var/www/web123/htdocs/index (None could be negotiated)., referer: https://www.subdomain.domain.de/


    -> Daraufhin habe ich in .httpd.conf folgendes eingefügt:


    Code
    AddType application/x-httpd-php .php


    Dann geht es. Fazit: Es sollte ggf. dieser o.g. AddType automatisch beim erstellen eines Vertrages gesetzt werden.
    Ist das möglich oder ist bei mir da nur ein Fehler?

  • Gibts mittlerweile einen Fix dafür in LC? Habe nämlich das selbe Problem und die .conf wird ja leider von LC neu Geschrieben und schon ist es wieder wech ...


    Mit Ubuntu 14.04

  • Leider stosse ich hier auf ein ähnliches Problem, Apache gibt mir unter Debian Jessie diesen Fehler aus:


    Code
    [negotiation:error] [pid 3211] [client 1.2.3.4:36781] AH00687: Negotiation: discovered file(s) matching request: /var/www/web60/htdocs/impressum (None could be negotiated)., referer: http://domain.de/


    php5-cgi ist installiert:


    Code
    apt-get install php5-cgi
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    php5-cgi is already the newest version.


    lcclient --diag



    cgi-Modul ist aktiviert:


    Code
    a2enmod cgi
    Module cgi already enabled


    liveconfig und lcclient wurden ebenfalls neu gestartet und auch mehrfach bei dem betreffenden Kunden etwas am Vertrag geändert, damit die Config neu erstellt wird, trotzdem bleibt der Fehler. Verwendet wird eine .htaccess-Datei mit folgenden Rewrite-Rules:


    Apache Configuration
    RewriteEngine on 
    
    
    RewriteRule ^([a-zA-Z0-9]*)/$ index.php?i=$1
    RewriteRule ^([a-zA-Z0-9]*)$ index.php?i=$1


    Habe ich irgendwo etwas übersehen?

  • Fehler gefunden:
    In Apache ist mod_negotiate per Standard aktiv. Da "Options MultiViews" gesetzt ist, hatte dies mit mod_rewrite kollidiert, da der Kunde zusätzlich folgende Dateien auf dem Webspace hatte:


    /impressum.php
    /kontakt.php
    usw.


    Ein mod_rewrite von domain.de/impressum funktionierte somit beispielsweise nicht mehr. Lösung: In der .htaccess-Datei MultiViews ausschalten:


    Options -MultiViews



    Bei der Kontrolle der übrigen Konfiguration ist mir desweiteren aufgefallen, dass php5-cgi nicht unter /etc/apache2/conf-enabled auftaucht. Mittels "a2enconf php5-cgi" kann dies natürlich geändert werden, da PHP als FastCGI-Variante derzeit aber einwandfrei läuft stelle ich mir die Frage, ob dies überhaupt aktiviert werden muss?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!