IMAP process_limit zu niedrig

  • Wir erhalten hin und wieder diese Fehlermeldung:


    Quote

    service(imap-login): process_limit (100) reached, client connections are being dropped


    Die Werte


    default_process_limit = X
    default_client_limit = X


    müssten hierfür angepasst werden. (/etc/dovecot/10-master.conf)
    Wenn in dieser Datei die Werte angepasst werden, wird dies vom System überhaupt berücksichtigt, oder gilt ausschließlich nur das, was in der Datei /etc/dovecot/dovecot.conf steht? Die Verwaltung von Devecot erfolgt über LiveConfig.


    Wie lässt sich das Problem am einfachsten lösen?

  • Leider ohne Funktion. Ich trage folgendes in die dovecot.local.conf ein:


    service imap-login {
    process_limit = 250
    }


    Anschließend wird die Konfiguration neu gespeichert.


    doveconf -d | grep default_process_limit zeigt folgendes:


    Quote

    doveconf: Warning: please set ssl_dh=</etc/dovecot/dh.pem
    doveconf: Warning: You can generate it with: dd if=/var/lib/dovecot/ssl-parameters.dat bs=1 skip=88 | openssl dhparam -inform der > /etc/dovecot/dh.pem
    default_process_limit = 100


    Der Wert wurde also gar nicht übernommen. Was ist da falsch?


    Ist es hoffentlich bald möglich, diesen Wert über LiveConfig einstellen zu können?

  • Hallo,


    taucht die dovecot.local.conf als include in der dovecot.conf auf?


    Quote

    # local configuration options
    !include_try /etc/dovecot/dovecot.local.conf


    Ich meinte mich erinnern zu können, dass die Datei nicht automatisch angelegt wird und nur dann inkludiert wird, wenn sie beim letzten Schreiben der Dovecot-Config aus LiveConfig heraus auch existiert.


  • Bei uns sieht die /etc/dovecot/dovecot.local.conf so aus:


    ----------------------------------------------------------------------------
    service imap-login {
    process_limit = 10240


    }


    service anvil {
    client_limit = 10240


    }
    service auth {
    client_limit = 10240
    }


    service stats {
    client_limit = 10240
    unix_listener stats-writer {
    user = mail
    group = mail
    }
    }


    default_client_limit = 1124
    default_client_limit = 11024
    ----------------------------------------------------------------------------


    und das funkttioniert bei uns einwandfrei....



    Gruß Ralf

  • Danke, exakt das habe ich so eingefügt, die config neu schreiben lassen, den Dienst neu gestartet, es wird einfach nicht übernommen.


    Kann es sein, dass dies unter Deb. 11 nicht funktioniert?


    doveconf -d | grep default_process_limit gibt immer noch 100 aus.


    Ich wäre für jeden hilfreichen Tipp dankbar.


  • Wir verwenden hier Debian 11.
    Mach mal ein


    doveconf | grep process_limit (statt default_process_limit ) und schau doch mal, wieviele Prozesse Dovecot bei Dir tatsächlich in der Spitze offen hat (ps -C dovecot | wc -l)


    Gruß Ralf

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!